Ergebnis 1 bis 5 von 5

Thema: Probleme mit Umlauten bei listings trotz inputenc und fontenc

  1. #1
    Registrierter Benutzer
    Registriert seit
    21.06.2009
    Beiträge
    24

    Probleme mit Umlauten bei listings trotz inputenc und fontenc

    Hallo zusammen!

    Ich habe Probleme in meinen Listings Umlaute darzustellen.
    Im restlichen Dokument klappt das mit den Umlauten ohne Probleme.
    Hier mein Beispiel:
    Code:
    \documentclass{scrbook}
    \usepackage[latin1]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage{listings}
    %true oder false ändert nichts an der Ausgabe
    \lstset{extendedchars=true}
    
    \begin{document}
    Häuser
    \begin{lstlisting} %als Option [extendedchars=true] auch keine Änderung
    Häuser
    ö
    \"o
    \end{lstlisting}
    \end{document}
    Das Ergebnis im pdf ist:
    Code:
    Häuser
    
    H\"{a}user
    \"{o}
    \"o
    Ich verwende die listings Version 1.4, WinEdt 5.5 und Vista.

    Hat jemand eine Idee, woran das liegen könnte?
    Das Ersetzen der Umlaute in WinEdt scheint ja auch nichts zu bringen.

    Danke

  2. #2
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    3.923
    Deaktiviere in winedt-Options-Setting-Tab Translations "TeX-Write". Du musst danach die Datei neu speichern (davor irgendwas ändern). Überprüfe ggfs. z.B. im Editor oder in notepad, dass die richtigen Umlaute in der Datei sind.

  3. #3
    Registrierter Benutzer
    Registriert seit
    21.06.2009
    Beiträge
    24
    Hi,

    ich habe die Translations jetzt mal deaktiviert.
    Dann funktionieren die Umlaute sowohl im Listings als im restlichen Bereich.

    Aber das kann ja nicht der Wahrheit letzter Schluss sein, ohne die Translation schränke ich doch die Kompatibiltät meiner Dateien ein.

    Wenn ich die Translation wieder aktiviere, wird folgendes gespeichert:
    Code:
    \begin{document}
    H\"{a}user 
    \begin{lstlisting}[extendedchars=true]
    H\"{a}user
    \"{o}
    \"{o}
    \end{lstlisting}
    \end{document}
    Der Befehl dazu in WinEdt sieht so aus "ä" -> "\""{a}".

    Das sieht doch alles richtig aus, oder?

    Warum funktionieren die Umlaute im listing aber nur ohne Translation?

    Danke schonmal für den ersten Tipp!

  4. #4
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    3.923
    Die Kompabilität wird durch inputenc sichergestellt, das ja die Kodierung der Datei deklariert. Bei aktivierten Translations bräuchtest du das Paket überhaupt nicht, weil deine Datei dann keine nicht-ASCII-Zeichen enthalten würde.

    Code:
    Warum funktionieren die Umlaute im listing aber nur ohne Translation?
    Weil listings eine Verbatim-Umgebung ist, die Befehle wie \section, \bfseries und eben auch \"a nicht ausführt, sondern einfach ausdruckt.

  5. #5
    Registrierter Benutzer
    Registriert seit
    21.06.2009
    Beiträge
    24
    Dann sage ich danke für den Tipp!

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •