Anzeige:
Ergebnis 1 bis 5 von 5

Thema: Biber 2.7: .bbl wird nicht kreiert

  1. #1
    Registrierter Benutzer
    Registriert seit
    30.05.2016
    Beiträge
    10

    Biber 2.7: .bbl wird nicht kreiert

    Gestern lief mein LaTeX noch einwandfrei, seit heute morgen zickt es rum. Ich kriege die Meldung:

    Code:
    INFO - This is Biber 2.7
    INFO - Logfile is 'FILENAME.blg'
    ERROR - FILENAME.bcf is malformed, last biblatex run probably failed. Deleted FILENAME.bbl
    INFO - ERRORS: 1
    Die entsprechende Stelle im .log file:
    Code:
    Package biblatex Info: No input encoding detected.
    (biblatex)             Assuming 'ascii'.
    Package biblatex Info: Automatic encoding selection.
    (biblatex)             Assuming data encoding 'ascii'.
    \openout4 = `FILENAME.bcf'.
    
    Package biblatex Info: Trying to load bibliographic data...
    Package biblatex Info: ... file 'FILENAME.bbl' not found.
    
    No file Geographic_Trade_and_Financing_Patterns_Within_the_Euro_Area.bbl.
    Package biblatex Info: Reference section=0 on input line 24.
    Package biblatex Info: Reference segment=0 on input line 24.
    Ich habe mich natürlich schon selbst auf die Pirsch gemacht, was da los ist. Was ich häufig gefunden habe war, dass Leute eine .bbl Datei mit bibtex erstellt haben und dann auf biber umgestiegen sind oder so, was wohl nicht klappt. Oder dass irgendwelche packages nicht funktionieren. Aber ich habe ja, wie gesagt, seit gestern nix geändert. Und zwar weder am .tex file noch am .bib. Mittlerweile habe ich mal alles auf die neueste Version geupdated, aber das Problem besteht, wie man sieht, weiterhin. Meine Präambel sieht so aus:

    Code:
    % !TeX spellcheck = en_US
    \documentclass[12pt]{article}
    \usepackage[onehalfspacing]{setspace}
    \usepackage[a4paper, margin=2.5cm]{geometry}
    \usepackage{mathptmx}
    \usepackage{amsmath}
    \usepackage{graphicx}
    \usepackage[hang]{caption}
    \usepackage{subcaption} 
    \usepackage[bottom]{footmisc}
    \usepackage{dcolumn} %makes r output work
    \usepackage{tabularx}
    \newcolumntype{L}[1]{>{\raggedright\arraybackslash}p{#1}}
    \newcolumntype{C}[1]{>{\centering\arraybackslash}p{#1}} 
    \newcolumntype{R}[1]{>{\raggedleft\arraybackslash}p{#1}} 
    \newcommand{\possessivecite}[1]{\citeauthor{#1}'s (\citeyear{#1})}
    \usepackage{pdfpages}
    \usepackage{hyperref}
    \usepackage{pdflscape}
    \usepackage{xcolor}
    \usepackage[backend=biber,style=authoryear-comp, sorting=nyt]{biblatex}
    \addbibresource{MasterThesisReferences.bib}

  2. #2
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    4.020
    Lösche mal die bcf-Datei und die aux-Datei und kompiliere alles neu. Wenn es dann immer noch nicht klappt, wirst du ein vollständiges Beispiel inkl. bib zeigen müssen. Präambel alleine reicht nicht.

  3. #3
    Registrierter Benutzer
    Registriert seit
    30.05.2016
    Beiträge
    10
    Zitat Zitat von u_fischer Beitrag anzeigen
    Lösche mal die bcf-Datei und die aux-Datei und kompiliere alles neu. Wenn es dann immer noch nicht klappt, wirst du ein vollständiges Beispiel inkl. bib zeigen müssen. Präambel alleine reicht nicht.
    Daran hatte ich tatsächlich schon gedacht, bevor ich gepostet habe, aber hab vergessen, das dazu zu schreiben. Funktioniert auch nicht. Hier also ein MWE plus die .bib:

    Code:
    % !TeX spellcheck = en_US
    \documentclass[12pt]{article}
    \usepackage[onehalfspacing]{setspace}
    \usepackage[a4paper, margin=2.5cm]{geometry}
    \usepackage{mathptmx}
    \usepackage{amsmath}
    \usepackage{graphicx}
    \usepackage[hang]{caption}
    \usepackage{subcaption} 
    \usepackage[bottom]{footmisc}
    \usepackage{dcolumn} %makes r output work
    \usepackage{tabularx}
    \newcolumntype{L}[1]{>{\raggedright\arraybackslash}p{#1}}
    \newcolumntype{C}[1]{>{\centering\arraybackslash}p{#1}} 
    \newcolumntype{R}[1]{>{\raggedleft\arraybackslash}p{#1}} 
    \newcommand{\possessivecite}[1]{\citeauthor{#1}'s (\citeyear{#1})}
    \usepackage{pdfpages}
    \usepackage{hyperref}
    \usepackage{pdflscape}
    \usepackage{xcolor}
    \usepackage[backend=biber,style=authoryear-comp, sorting=nyt]{biblatex}
    \addbibresource{MasterThesisReferences.bib}
    
    \begin{document}
    	\begin{onehalfspace}
    		
    		This is a test
    		
    		\textcite{LaneMilesiFerretti.2014}
    		
    		\pagebreak
    		\printbibliography
    		
    	\end{onehalfspace}
    \end{document}
    Angehängte Dateien Angehängte Dateien

  4. #4
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    4.020
    Funktioniert tadellos. Scheitert wirklich genau dieses Beispiel? Wenn ja, wie ist der Name der Datei? Hast du sie zum Testen in einen leeren Ordner kopiert (mit der bib)?

  5. #5
    Registrierter Benutzer
    Registriert seit
    30.05.2016
    Beiträge
    10
    Edit (16.15 Uhr): Ich habe das Problem identifizieren können. Eine Grafik war unsinnig formatiert. Warum dann allerdings biber anfängt zu nörgeln, verstehe ich nicht ganz. Es handelt sich um eine R-Grafik, die in einem PDF gespeichert ist.
    Geändert von Katzenscheucher (30-06-2017 um 15:16 Uhr)

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •