Anzeige:
Ergebnis 1 bis 3 von 3

Thema: Probleme mit Fußnoten in einer tabularx-Tabelle mit dem hyperref-Paket

  1. #1
    Registrierter Benutzer
    Registriert seit
    24.04.2009
    Beiträge
    204

    Probleme mit Fußnoten in einer tabularx-Tabelle mit dem hyperref-Paket

    Hallo zusammen,

    ich möchte Fußnoten (bzw. mit kleinen Buchstaben nummerierte Tabellenfußnoten) in einer tabularx-Tabelle. Das funktioniert auch soweit. Sobald ich jedoch zusätzlich das hyperref-Paket lade, werden die Fußnotentexte nicht mehr angezeigt. Das Problem verschwindet wieder, wenn ich von tabularx auf tabular umsteige.

    Hier ist ein entsprechendes Minimalbeispiel:
    Code:
    \documentclass{scrreprt}
    
    \usepackage[ngerman]{babel}
    \usepackage[utf8]{inputenc}
    
    \usepackage{tabularx}
    
    %\usepackage{tablefootnote}
    %\usepackage{hyperref}
    
    \begin{document}
    
    \begin{table}
      \caption{Beschriftung}
      \label{tab:test}
    	\centering
    	\begin{minipage}{\linewidth}
    		\begin{tabularx}{\textwidth}{ll}
    			1. Spalte\footnote{Hier kommt eine erste Fußnote.\label{foot:erste_fussnote}} & 2. Spalte\footnote{Hier kommt eine zweite Fußnote.\label{foot:zweite_fussnote}} \\
    			bla\footref{foot:erste_fussnote} & blub\footref{foot:zweite_fussnote} \\
    			ble\footref{foot:erste_fussnote} & blob\footref{foot:zweite_fussnote} \\				
    		\end{tabularx}
    	\end{minipage}
    \end{table}
    
    \end{document}
    Hat jemand noch eine Idee zur Lösung des Problems, Fußnoten, footref, tabularx und hyperref zur Zusammenarbeit zu bewegen?

  2. #2
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    4.035
    \usepackage[hyperfootnotes=false]{hyperref}

  3. #3
    Registrierter Benutzer
    Registriert seit
    24.04.2009
    Beiträge
    204
    Okay, vielen lieben Dank. Das löst schon mal das Hauptproblem.

    Einen kleinen Schönheitsfehler gibt es allerdings noch. Das jeweils erste Auftreten einer Fußnote per \footnote wird von hyperref nicht verlinkt (und in der PDF-Datei auch entsprechend nicht rot umrahmt), die folgenden Verweise per \footref dagegen schon.

    Kann man das noch irgendwie anpassen, also z.B. das erste Auftreten einer Fußnote per \footnote manuell verlinken?

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •