mrunix.de

Zurück   mrunix.de > Applikationen > LaTeX-Forum
Benutzername
Kennwort
Registrieren Hilfe Benutzerliste Kalender Suchen Heutige Beiträge Alle Foren als gelesen markieren

LaTeX-Forum LaTeX, LyX, BibteX, PDF & Co

Antwort
 
Themen-Optionen Thema bewerten Ansicht
Alt 23-05-2007, 10:17   #1
symab
Registrierter Benutzer
 
Registriert seit: 17.04.2007
Beiträge: 39
color package

Hallo Leute,

habe folgendes Problem: ich benutze kile und beim Umwandeln meines codes kommt folgende Fehlermeldung: Missing \begin{documnet}

habe folgenden Anfang:

%Schriftgröße, Layout, Papierformat, Art des Dokumentes
\documentclass[12pt,twoside,a4paper]{report}

\usepackage{a4}

%neue Rechtschreibung
\usepackage{ngerman}

%Grafiken einbinden
\usepackage{epsfig}
\usepackage {graphicx} % Grafiken einbinden, Option "draft" fuer leere Rahmen [draft]
\graphicspath{{bilder/}}
\usepackage{subfigure} % subfigures
\usepackage{pstricks} % Farben, einfache Zeichenelemente
\usepackage[rflt]{floatflt}
\usepackage{here}


% Farben/Schriftfarben
\usepackage{color}
\newcommand{\Rot}{\color{red}}

%Umlaute ermöglichen
\usepackage[latin1]{inputenc}

%Kopf- und Fußzeile
\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhf{}

%Kopfzeile mitztig
\fancyhead[CO,CE]{\nouppercase{\leftmark}}
%Linie oben
\renewcommand{\headrulewidth}{0.5pt}

%Fußzeile mittig
\fancyfoot[CO,CE]{\thepage}
%Linie unten
\renewcommand{\footrulewidth}{0.5pt}

\begin{document}
...
..
.


Das hat auch alles mal funktioniert und ich kann mir nicht erklären warum es jetzt nicht mehr funktioniert... wenn ich allerdings \usepackage{color} ausklammere funktioniert alles wieder... jedoch bin ich auf dieses package angewiesen, da ich in meinem dokument auch farbige texte verwende. Kann mir jemand helfen?

Vielen Dank!
symab ist offline   Mit Zitat antworten
Alt 23-05-2007, 10:27   #2
Salnic
Registrierter Benutzer
 
Registriert seit: 10.01.2005
Beiträge: 979
Hi symab,

am Code liegt es nicht, der lässt sich compilieren. Vielleicht ist aber Dein color-Packet fehlerhaft? Ich würde es einfach mal deinstallieren und neu installieren, solle mit dem Packet-Manager problemlos gehen.

Kannst auch statt color xcolor (http://www.ctan.org/tex-archive/macr...ontrib/xcolor/) probieren. Sollte auch standardmäßig installiert sein.

Salnic
Salnic ist offline   Mit Zitat antworten
Alt 23-05-2007, 10:42   #3
Stefan_K
Registrierter Benutzer
 
Benutzerbild von Stefan_K
 
Registriert seit: 05.04.2007
Ort: Hamburg
Beiträge: 3.515
compilierbar mit KILE

Hi Symab,

dito: bei mir läßt es sich auch compilieren. Und ich habe sogar KILE benutzt. Am besten mal Salnics Tip versuchen.
Aber was anderes: welche Distribution verwendest Du eigentlich? SUSE, Debian, Ubuntu .. ? Mir stach nur eben die Zeile \usepackage[latin1]{inputenc} ins Auge, da Ubuntu und Debian (seit Etch) standardmäßig UTF8 Encoding verwenden.

Grüße,

Stefan
Stefan_K ist offline   Mit Zitat antworten
Alt 23-05-2007, 11:13   #4
countbela666
Registrierter Benutzer
 
Benutzerbild von countbela666
 
Registriert seit: 15.04.2005
Ort: Berlin
Beiträge: 2.317
Hallo, symab,

ich könnte mir vorstellen, dass deine LaTeX-Installation veraltet ist. Folgende Ausgabe im LOG-File erhältst du mit aktuellen Paketen, wenn du deinem Code ein \listfiles voranstellst:
Code:
 *File List*
  report.cls    2005/09/16 v1.4f Standard LaTeX document class
  size12.clo    2005/09/16 v1.4f Standard LaTeX file (size option)
      a4.sty    2004/04/15 v1.2g A4 based page layout
 ngerman.sty    1998/07/08 v2.5e Support for writing german texts (br)
  epsfig.sty    1999/02/16 v1.7a (e)psfig emulation (SPQR)
graphicx.sty    1999/02/16 v1.0f Enhanced LaTeX Graphics (DPC,SPQR)
  keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
graphics.sty    2006/02/20 v1.0o Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    1999/03/16 v1.09 sin cos tan (DPC)
graphics.cfg    2005/12/29 v1.2 MiKTeX 'graphics' configuration
   dvips.def    1999/02/16 v3.0i Driver-dependant file (DPC,SPQR)
subfigure.sty    2002/07/30 v2.1.4 subfigure package
subfigure.cfg
pstricks.sty    2006/08/10 v0.32 LaTeX wrapper for `PSTricks' (RN,HV)
pstricks.tex    2006/12/22 v1.15 `PSTricks' (tvz)
  xcolor.sty    2007/01/21 v2.11 LaTeX color extensions (UK)
   color.cfg    2005/12/29 v1.1 MiKTeX 'color' configuration
floatflt.sty    1996/02/27 v. 1.3
    here.sty    
inputenc.sty    2006/05/05 v1.1b Input encoding file
  latin1.def    2006/05/05 v1.1b Input encoding file
fancyhdr.sty    
 ***********
Außerdem ist es für das Beispiel völlig unerheblich, ob du color als Paket lädtst oder nicht, da pstricks bereits xcolor lädt, was wiederum ein Nachladen von color verhindert, wie man im LOG anhand des fehlenden Eintrags für color.sty auch erkennt.

Weiterhin könntest du mal einen Blick in das LaTeX-Sündenregister l2tabu werfen, da viele der von dir verwendeten Pakete/Befehle veraltet und/oder obsolet sind (a4 und epsfig ersatzlos streichen, subfigure durch subfig ersetzen, die Nutzung von \graphicspath überdenken etc.).

Grüße
Marcel
__________________

Listen to me children of the night, beyond the doors of darkness you will find
a thousand worlds for you to see here, take my hand and follow me...

Geändert von countbela666 (23-05-2007 um 11:15 Uhr)
countbela666 ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist an.

Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 06:16 Uhr.


Powered by vBulletin® Version 3.8.7 (Deutsch)
Copyright ©2000 - 2014, vBulletin Solutions, Inc.